> That got both 2.2.5 and 2.3b1 to start up with my data. Only
> problem is that
> all instances of the ZClass I had created in my product (which I named
> ArticleProduct, btw) are broken in 2.3b1. The product itself
> appears in the
> Product Management menu, but even instances of ZClasses within the product
> are broken. Re-importing ArticleProduct.zexp does no good... I still get
> that "append" AttributeError (see traceback below). Is this a bug w/ 2.3b1
> or am I missing something?

This sounds like a bug that pre-dates 2.3 - have you tried
using Shanes 'ZGlobals Repair' utility?


If not, can you give it a shot and let me know if it fixes the
problem? If so, I'm inclined to weave a version of Shane's
workaround into the core for 2.3 to mitigate this sort of problem.


Brian Lloyd        [EMAIL PROTECTED]
Software Engineer  540.371.6909
Digital Creations  www.digicool.com

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to