>
> >This may seem like a silly response, but have you tried the same select
> >statement from outside zope - say from the mysql client?  perhaps your
> >select statement is truly returning an empty set.  We use zope with
> >PostgreSQL and MySQL (and have been for a few years) and haven't had any
> >problems.
> >
>
>This is some good advice - Also, just based on your example - you could
>be connected to your database (test) correctly, but you need to have a table
>called test for the query to work - you didn't really state if you had a
>table
>called test.

Hi Dave.

Yes it is. In my original message I had indicated that I tried executing my 
queries in the mysql client, as well as through the API of MySQL-python; 
both worked just fine.

As it turns out, I had downloaded an "old" copy of ZMySQLDA. There are a 
number of pages that each imply that they link the latest version of this 
product. The link from www.zope.org itself 
(http://www.zope.org/Products/external_access) has two entries for this 
product! I downloaded 1.2.0, but apparently 2.0.1 is available, which works 
with Zope 2.3.0.

Paul Johnson was the kind soul who provided me with the link to the 
"correct" version of ZMySQLDA (http://www.zope.org/Members/adustman/ZMySQLDA).


Gerald.



_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to