Very strange that you don't get an error though.
Your DTML is wrong. You're not sending the _value_ or 'value' you're sending
a value that looks like this: "<dtml-var value>"

Here's the correct way.
<dtml-let value="'Test'">
<dtml-in expr="sql_query(para=value)">


Peter


----- Original Message -----
From: "Axel Missbach" <[EMAIL PROTECTED]>
To: <[EMAIL PROTECTED]>
Sent: Wednesday, January 31, 2001 4:52 PM
Subject: [Zope] Parameter from DTML-Document to SQL-Method


> Hi to all,
>
> I am trying a long time to get the result of an query in the document,
> or perhaps get the parameter in the query.
> It looks like this:
>
> <dtml-let value="'Test'">
> <dtml-in expr="sql_query(para='<dtml-var value>')">
>
> <dtml-var code>   #code is part of the query-result
> .
> .
> </dtml-let>
>
> Viewing the document, i got no result (and no error).
> Testing the query with value= Test, the result is ok!
>
> thanks very much in advance
>
> axel
>
> _______________________________________________
> Zope maillist  -  [EMAIL PROTECTED]
> http://lists.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://lists.zope.org/mailman/listinfo/zope-announce
>  http://lists.zope.org/mailman/listinfo/zope-dev )
>


_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to