Dave Whiteley wrote:

I am very new to zope, and I am not an experienced lisp programmer -
please accept the standard Newbie apologies. I am avoiding the use of
DHTML, as this seems to be the approved policy. Most of my work has
been using page templates, and internal and external python scripts.

I am trying to use Xemacs to develop and maintain a site that I
created via the web interface.  I have connected using the xemacs ftp
link, and can edit.  I have a couple of problems.

Firstly, my xemacs did not recognise my Script(Python) files as being
Python, and so it does not automatically switch to Python Major Mode.

I added the standard shebang "#! /usr/bin/python" to the start of the
file which fixed this. However it would be nice if it were to
recognise Zope's script preamble.  Please could someone point me at a
resource to help me configure my Xemacs for this.

Secondly, I found that after I had edited a script the web interface
no longer showed the file as a python script, but as a DHTML
file. When used, I just saw the script contents. Is this related to my
adding the shebang?  I have now removed it again, but it has not fixed
the problem.

Is there any way I can switch them back (without using copy and
paste)?  How do I avoid this happening?

I am using Debian "Sarge" Linux, which provides Zope 2.7.


See http://www.plope.com/Books/2_7Edition/ExternalTools.stx#3-24 and


Zope maillist - Zope@zope.org
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to