Hi ,

I've instantiated a Group User Folder object for my Zope+Plone application and configured it to take users from an LDAP server in order to get users id and passwords validated against LDAP. So far, so good users can log in using their LDAP credentials.

The underlying usersâ source is a LDAPUserFolder. I have configured it so that the groups are not stored on LDAP. Consequently the groups' source is default UserFolder.I have also configured Anonymous,Member as default roles to LDAP users.

I'm using ZOPE (ver.Zope 2.7.5-final, python 2.3.5, linux2) and Plone ( GRUF version: 3.1.1 and LDAPUserFolder 2.4 on Debian box.
All except LDAPUserFolder installed from debian packages.

I have encountered problems with assigning other roles to users. When I enter acl_users/Users tab of my Plone site check one of the users and the role I want to assign, confirm it I get the following error:
Site error:

This site encountered an error trying to fulfill your request. The errors were:

Error Type
Error Value
    'NoneType' object has no attribute 'find'
Request made at
    2005/05/11 11:04:33.681 GMT+2

The full stack trace from error log is as follows:

Exception Details
Back to Error Log

    2005/05/11 11:07:35.111 GMT+2
User Name (User Id)
    zopeadmin (zopeadmin)
Request URL
Exception Type
Exception Value
    'NoneType' object has no attribute 'find'

Traceback (innermost last):

* Module ZPublisher.Publish, line 101, in publish
* Module ZPublisher.mapply, line 88, in mapply
* Module ZPublisher.Publish, line 39, in call_object
* Module Products.GroupUserFolder.GroupUserFolder, line 1372, in changeOrCreateUsers
* Module Products.GroupUserFolder.GroupUserFolder, line 1110, in _updateUser
* Module Products.GroupUserFolder.GroupUserFolder, line 1057, in _doChangeUser
* Module Products.GroupUserFolder.LDAPUserFolderAdapter, line 138, in _doChangeUser
* Module Products.LDAPUserFolder.LDAPUserFolder, line 1497, in manage_editUserRoles

AttributeError: 'NoneType' object has no attribute 'find'

Display traceback as text
changeOrCreateUsers 'Change'
default_password '<password obscured>'
new_users []
users ['bernard']
roles ['Reviewer']
cookieTest '1'
__ac_name 'bernard'
__ac 'YmVybmFyZDoxMjNhYmM%3D%0A'
_ZopeId '63617490A10pAKsRfQA'
lazy items
SESSION <bound method SessionDataManager.getSessionData of <SessionDataManager instance at 420c05f0>>
TraversalRequestNameStack []
roles ['Reviewer']
URL 'http://myhost:9673/copy_of_plone/acl_users/changeOrCreateUsers'
SERVER_URL 'http://myhost:9673'
PATH_INFO '/copy_of_plone/acl_users/changeOrCreateUsers'
PUBLISHED <bound method GroupUserFolder.changeOrCreateUsers of <GroupUserFolder instance at 41924da0>>
default_password '<password obscured>'
new_users []
ACTUAL_URL 'http://myhost:9673/copy_of_plone/acl_users/changeOrCreateUsers'
users ['bernard']
URL0 http://myhost:9673/copy_of_plone/acl_users/changeOrCreateUsers
URL1 http://myhost:9673/copy_of_plone/acl_users
URL2 http://myhost:9673/copy_of_plone
URL3 http://myhost:9673
BASE0 http://myhost:9673
BASE1 http://myhost:9673
BASE2 http://myhost:9673/copy_of_plone
BASE3 http://myhost:9673/copy_of_plone/acl_users
BASE4 http://myhost:9673/copy_of_plone/acl_users/changeOrCreateUsers
HTTP_COOKIE 'cookieTest=1; tree-s="eJzTyCkw5NLIKTDiClZ3hANXW3WuAmOuRKCECUjWFEXWFyRrBpY1B8laAGVDci1LowJtQTKWXIlAABQ3NEDS5pxfDpI0NOSCyCFb6JqbD5YzhsqZIMn5ZTuC5UzBpuoBAF0OLNI"; _ZopeId="63617490A10pAKsRfQA"; __ac="YmVybmFyZDoxMjNhYmM%3D%0A"; __ac_name="bernard"'
SERVER_SOFTWARE 'Zope/(Zope 2.7.5-final, python 2.3.5, linux2) ZServer/1.1 Plone/2.0.4'
channel.creation_time 1115802248
CONNECTION_TYPE 'keep-alive'
HTTP_ACCEPT_CHARSET 'ISO-8859-1,utf-8;q=0.7,*;q=0.7'
HTTP_USER_AGENT 'Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050324 Debian/1.7.6-1'
HTTP_REFERER 'http://myhost:9673/copy_of_plone/acl_users/manage_users?FORCE_ALL=1'
SERVER_NAME 'myhost.man.poznan.pl'
PATH_TRANSLATED '/copy_of_plone/acl_users'
HTTP_HOST 'myhost:9673'
HTTP_ACCEPT 'text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5'
CONTENT_TYPE 'application/x-www-form-urlencoded'
REMOTE_HOST 'ldaphost.man.poznan.pl'
PATH_INFO '/copy_of_plone/acl_users'

I get similiar error message when I try to assign a user to any group.

Another problem is that I sometimes when I click on the Users' tab I get a list of users who already logged in, sometimes I get no users and I have to use separate link to force their retrieval (there is a message: "It is reported that 106 users stand in the various user sources.It might be very long to retreive the whole list but you can force it by Clicking here.").

Has anybody any idea how to get this things to work? I must be able to assign Reviewers role to some of my users, otherwise nobody would be able to publish anything....

Zope maillist - Zope@zope.org
** No cross posts or HTML encoding! **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to