I also get this error a lot when trying to add an object through the ZMI in an Apeified folder:

   * Module ZPublisher.Publish, line 92, in publish
   * Module ZPublisher.BaseRequest, line 302, in traverse
   * Module App.FactoryDispatcher, line 29, in __bobo_traverse__
   * Module App.Product, line 67, in _product

AttributeError: OFSP

Sometimes I can clear it out by trying to add a different type of object.

Is that likely just a 2.7 Ape issue, as well?


Shane Hathaway wrote:

Tim Connor wrote:
Thanks, Shane.  That fixes the problem of Zope not starting, and better
than the other syntax I tried, but it still doesn't fix the core
problem.  My root Ape installs have issues with adding a local role, as
then the default roles get axed.  If you add this fix then Zope re-adds
Owner (and Authenticated, as you need to duplicate the fix a couple
lines lower) during the start-up, but not Manager - and they are not
really added, but sort of hacked in by the start-up code.  Shouldn't Ape
be somehow dealing with this exact situation anyways, or is there just
something wrong with my installs?

I'll look at it.  Ape hasn't been tested with the most recent versions
of Zope 2.7.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to