This bounced around on the list recently. It is supposed to be fixed now but 
the solution is modifying the source and changing how the batching is done. It 
works if less than 20 records returned...blows up if more. You can test this by 
forcing your query to only return a few records. Can't remember the exact 
location of the code now. Will see what I can find it.

Allen


Dennis Allison wrote:

I've never had any problem with parameterless queries.  (-:

No, this is a simple case of a parameter somehow being lost in the ZMI interface.

On Tue, 7 Jun 2005, Joe Bezier wrote:


Hi there,

By any chance are you trying to test a ZSQL method that doesn't (shouldn't) need any query parameters? For some reason (and I'm not the guy who can tell you why...) these types of tests always break - try adding '?query=' to the end of the URL. and see if that helps.

Cheers,

Joe.
On 7 Jun 2005, at 11:41, Dennis Allison wrote:


Zope 2.7.6
Python 2.3.5
MySQLDA-1.2.1c3
ZMYSQLDA-2.09b3


Site Error

An error was encountered while publishing this resource.

Error Type: KeyError
Error Value: 'query'

Troubleshooting Suggestions

   * This resource may be trying to reference a nonexistent object or
variable 'query'.
   * The URL may be incorrect.
   * The parameters passed to this resource may be incorrect.
   * A resource that this resource relies on may be encountering an
error.


----------
Error log:

2005/06/07 03:33:03.344 GMT-7
User Name (User Id) allison (allison)
Request URL http://group1.agilemind.com/Scratch/simpleq/manage_test
Exception Type KeyError
Exception Value 'query'

Traceback (innermost last):

   * Module ZPublisher.Publish, line 101, in publish
   * Module ZPublisher.mapply, line 88, in mapply
   * Module ZPublisher.Publish, line 39, in call_object
   * Module Shared.DC.ZRDB.DA, line 337, in manage_test
   * Module DocumentTemplate.DT_String, line 474, in __call__
   * Module DocumentTemplate.DT_In, line 602, in renderwb
   * Module DocumentTemplate.DT_Var, line 219, in render

KeyError: 'query'


There does not seem to be a bug like this in the collectors.

Any help/pointers appreciated.


_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )



                
___________________________________________________________ How much free photo storage do you get? Store your holiday snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com



_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to