--On 20. Juni 2005 16:43:53 -0500 tyson <[EMAIL PROTECTED]> wrote:

    I got zope 2.8 installed on fedora core 4.  Whenever I execute this
command to start zope  /usr/local/zope/instance/bin/runzope,  I get this

Error: The object named by "DBTab.ClassFactories.autoClassFactory" could
not be imported

Traceback (most recent call last):
  File "/usr/local/zope/lib/python/Zope2/Startup/datatypes.py", line 93,
in importable_name
    package = __import__(n, g, g, component)
  File "/usr/local/zope/lib/python/DBTab/ClassFactories.py", line 18, in ?
    import OFS.Uninstalled
  File "/usr/local/zope/lib/python/OFS/Uninstalled.py", line 16, in ?
    import  SimpleItem, Globals, Acquisition
  File "/usr/local/zope/lib/python/OFS/SimpleItem.py", line 25, in ?
    import Globals, App.Management, Acquisition, App.Undo
  File "/usr/local/zope/lib/python/Globals.py", line 23, in ?
    import Acquisition, ComputedAttribute, App.PersistentExtra, os
  File "/usr/local/zope/lib/python/App/PersistentExtra.py", line 16, in ?
    from class_init import default__class_init__
  File "/usr/local/zope/lib/python/App/class_init.py", line 14, in ?
    from AccessControl.PermissionRole import PermissionRole
  File "/usr/local/zope/lib/python/AccessControl/__init__.py", line 17,
in ?
    from Implementation import setImplementation
  File "/usr/local/zope/lib/python/AccessControl/Implementation.py", line
98, in ?
  File "/usr/local/zope/lib/python/AccessControl/Implementation.py", line
51, in setImplementation
    from AccessControl import ImplC as impl
  File "/usr/local/zope/lib/python/AccessControl/ImplC.py", line 29, in ?
    from ImplPython import RestrictedDTML, SecurityManager
ImportError: No module named ImplPython

(line 914 in file:///usr/local/zope/instance/etc/zope.conf)
For help, use /usr/local/zope/lib/python/Zope2/Startup/run.py -h

I noticed that this affected other people from some discussions, but I
couldn't find any solution.  Does anybody have an idea where I can start?
My buddy got his working on fedora core 4 fine, so it shouldn't be a
problem. When I first compiled zope, I used this command.  "./configure
--prefix=/usr/loca/zope --with-python=/usr/bin/python2.4".  Any help
would be much appreciated!

Try to compile Zope with a *fresh* Python 2.3.X installation and not with the FC4 Python. 2.4 is btw. not supported as documented and and as posted a hundred times.


Attachment: pgpchYyuwPzBX.pgp
Description: PGP signature

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to