Thanks a lot for your help, Dieter, Greg, and Andy!

Dieter, you were absolutely right about the broken instances. All I had to
do was delete ZSQLMethods from my Products folder and restart Zope.
Everything was all right after that.

Andy and Greg, so far I did not have any problems using mysqlpython 1.2.0
with ZMySQLDA 2.0.8. But since Andy is the expert I now installed 2.0.9b3
and am happy with it.

:-) Cheers and thanks again,

Ragnar


On Tue, 28 Jun 2005 19:43:15 +0200
Dieter Maurer <[EMAIL PROTECTED]> wrote:

> Ragnar Beer wrote at 2005-6-27 18:50 +0200:
> >After upgrading Zope from version 2.6.4 to 2.8.0 and mysqlpython from
> >0.9.2 to 1.2.0 I cannot add or edit ZSQLMethods anymore, although there
> >is an open(MySQL)db-Connection that works just fine with the same
> >ZSQLMethods that cannot be edited or with external methods. The error
> >I'm getting is: 
> >
> >"There are no SQL database connections. You need to add a Zope SQL
> >database connection before you can edit a Zope SQL Method."
> 
> Almost surely, your "ZMySQLDA" instances are broken (and then
> do not behave as "SQL database connection" instances).
> 
> Check your Zope logfile for messages of the form
> "could not install product...".
> 
> -- 
> Dieter
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists - 
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope-dev )
> 


_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to