Hiya,

I had a strange problem today, on a Zope 2.5 installation (yes, it will be upgraded soon...). Basically, I've got a form action which calls manage_changeProperties() on a number of subfolders using


<dtml-call expr="folder_place.manage_changeProperties(order=number)">

Now, this works absolutely fine throughout my installation, but in one instance it was raising an Unauthorized Error for all users, no matter what their permissions/roles:

Site Error

An error was encountered while publishing this resource.

Unauthorized
You are not authorized to access manage_changeProperties.

So I tried pretty much everything - checking all sorts of permissions and other stuff, but eventually made a copy of the folder, to make sure it wasn't something peculiar with the folder name - the copy worked perfectly. So, I then replaced the original folder with the folder copy and this worked fine too.

So, basically, problem solved. But I'm now concerned - could this happen again? Is there something I'm missing? Has anyone experienced something like this before?

Cheers,

JB


                
___________________________________________________________ How much free photo storage do you get? Store your holiday snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to