Hi Ashely,

I use Interbase (and Firebird) in Zope regularly and I just use the regular ZSQL Method syntax for blob fields:


<dtml-sqlvar name="blob_fld" type="nb">

to update the field.If the field may be left null, I usually use something like this in the ZSQL Method:

<dtml-if blob_fld>
<dtml-sqlvar name="blob_fld" type="nb">
<dtml-else>
null
</dtml-if>

Apply commas at the end (or beginning) of the <dtml-sqlvar> and null if necessary.

This should work for Interbase from version 4.x thru Interbase 6.x and for all versions of Firebird.

If you need further help, just email me (and the list). Also, there is a Zope-DB list for discussing Zope and RDBMS issues and the real gurus hang out there.

HTH

Bob Corriher
CTO
P-Wave Inc.

Ashley wrote:

Hi bobb, thanks for your reply.

If I found the right post (reading an image from blob in mysql and
displaying it), then thanks very much but I don't think it'll apply too much
to my situation. I can retrieve the contents of the blob field fine, its
updating it that causes the problems.

Thanks again, though.

I posted directly out of Outlook Express, by the way, just hitting "New
Post".

Kind regards

Ashley



"bobb" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]

I posted some stuff I was doing some time ago w/ mysql / blobs and zope
some

time ago so that my grandchildren could google for it :)...

if you goggle for zope mysql blob bobb
you'll get it.  It's not interbase.
hth

bobb

Also, your post came through as a newsgroup posting, which means I had to
cut / paste / finagle the whole thing to reply... It's the first time I've
ever seen that (I use m$ outlook express) How are you posting to here?
(curious, that's all)

"Ashley" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]
> I'm not sure if this is the right place for this, if not, my apologies.
>
> I've got a Clients table in an interbase db with various fields, one of
> which is a BLOB field (subtype text), used to maintain some notes.
>
> When inserting a Client into the table, this field populates fine.
>
> However, when attempting to update the client, for some reason, it
won't.

It
> just will not allow me to do an update with the notes field in the
> statement. I've googled around, and found lots of bits helping with
Delphi,
> and lots of statements that BLOB fields in Interbase are tricky to
update,

> but nothing that helps.
>
> Has anyone out there found a way around this?
>
> I'm using currently using gvib as my database adaptor, as kinterbase
does

> not seem to want to install at all (seemingly problems with ldap ..).
>
> My Zope instance is installed from a Plone installer.
>       Zope Version  (Zope 2.6.1 (binary release, python 2.1, win32-x86),
> python 2.1.3, win32)
>       Python Version  2.1.3 (#35, Apr 8 2002, 17:47:50) [MSC 32 bit
(Intel)]
>       System Platform  win32
>
>
> Thanks in advance
> Ashley
>
>
>
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope-dev )

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )






------------------------------




--
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.338 / Virus Database: 267.9.7/60 - Release Date: 7/28/2005

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to