Hi Bob, thanks again!!

When attempting to update the entity, I get the following error details:

Error Type ProgrammingError

Error Value (-413, 'execute.isc_dsql_execute: conversion error from string
"BLOB". ')

Error Trace Traceback (most recent call last):
File "C:\Program
Files\ESOPPlone\Zope\lib\python\DocumentTemplate\DT_Try.py", line 149, in
render_try_except
result = render_blocks(self.section, md)
File "C:\Program
Files\ESOPPlone\Zope\lib\python\DocumentTemplate\DT_Util.py", line 201, in
eval
return eval(code, d)
File "", line 2, in f
File "C:\Program Files\ESOPPlone\Zope\lib\python\Shared\DC\ZRDB\DA.py", line
428, in __call__
else: result=DB__.query(query, self.max_rows_)
File "C:\Program
Files\ESOPPlone\Zope\lib\python\Products\kinterbasdbDA\db.py", line 198, in
query
self.cursor.execute(src)
File "C:\Program
Files\ESOPPlone\Zope\lib\python\Products\kinterbasdbDA\kinterbasdb\__init__.
py", line 585, in execute
res = _kinterbasdb.execute(self._C_cursor, sql, params)
ProgrammingError: (-413, 'execute.isc_dsql_execute: conversion error from
string "BLOB". ')

I get the same error type and value when testing the SQL method (I've tried
to isolate the problem in its own method, leaving the updates to other
fields in a seperate SQL method) in the ZMI, and the SQL that is generated
is:
UPDATE ENTITY
SET EN_NOTES = 'Hello world'
WHERE EN_KEY = 12
Simple!

The metatata of the table has the notes field definition as:
EN_NOTES                  BLOB SUB_TYPE 1 SEGMENT SIZE 80,

There is nothing else of any real interest in the table - an update that
does not involve the notes works perfectly!

Thanks once again to you and everyone who has tried to help!

Cheers
Ashley

----- Original Message ----- 
From: "Bob Corriher" <[EMAIL PROTECTED]>
To: "Ashley Lloyd" <[EMAIL PROTECTED]>; <zope@zope.org>
Sent: Wednesday, August 03, 2005 2:31 PM
Subject: Re: [Zope] RE: Blobs in Interbase


> Hi Ashley,
>
> One down, one to go. I've used this adapter with Interbase 6.0 with no
> problems, although I've since upgraded to Firebird.
>
> Perhaps you could send the error traceback you get, we could get some
> clues from that. Also, the metadata from the table that shows the
> problem. It's got to be in there somewhere.
>
> Bob Corriher
> CTO
> P-Wave Inc.
>
>
> Ashley Lloyd wrote:
>
> > Bob, you're a star!
> >
> > I unpacked it, restarted Zope, and there it was!
> >
> > Marvellous, I've now got a kinterbase installed that works.
> >
> > Thats the good news.
> >
> > The bad news is I still can't update the blob field - I still get
> > errors. I think, unless anyone here has any more ideas, I'll have to
> > go and bother people in another mailing list.
> >
> > I've tried absolutely everything I can think of - sqlvar tags of type
> > string and nb, trying cast(... as blob) in the sql (doesn't seem to
> > work), I've even just tried setting it to 'Hello world', without using
> > any dtml variables at all, and it won't accept it.
> > From what I've read elsewhere, there are tools in some software
> > (mostly for Delphi I believe), that will allow updates of text blob
> > fields, so I was hoping that kinterbasdb had something in it as well,
> > but if it does, it isn't working on mine!!
> >
> > The interbase version is 6.0-6.1, if that jogs any memories for anyone.
> >
> > Thanks once again to everyone who has tried to help me.
> >
> > Kind regards
> >
> > Ashley
> >
> >
> >     Ashley Lloyd wrote:
> >
> >>Hi Bob,
> >>
> >>If you don't mind doing that, I'd really appreciate it.
> >>Nothing I seem to be trying to install at the moment seems to be
working.
> >>
> >>As with Phil, mine is from a Plone install, but I have got other
versions of
> >>Python elsewhere, (I think there's even an old Zope standalone instance
> >>still lurking somewhere, altho I don't think it can run) just to confuse
> >>matters.
> >>Anyway, my Zope is even older - 2.6.1, so hopefully it'll be compatible.
> >>
> >>Thanks very much again for your help.
> >>
> >>Ashley
> >>
> >>----- Original Message ----- 
> >>From: "Bob Corriher" <[EMAIL PROTECTED]>
> >>To: <[EMAIL PROTECTED]>
> >>Cc: "Ashley Lloyd" <[EMAIL PROTECTED]>; <zope@zope.org>
> >>Sent: Tuesday, August 02, 2005 4:01 PM
> >>Subject: Re: [Zope] RE: Blobs in Interbase
> >>
> >>
> >>
> >>
> >>>Hi Phil & Ashley,
> >>>
> >>>I also have kinterbasedbDA working on Windows. It is with an older
> >>>version of Zope (2.6.4). The DA version is 1.1.1.1. The kinterbasdb
> >>>version is 3.0.1. It uses a dll called _kinterbasedb.dll, instead of a
> >>>pyd. I don't remember the exact installation process anymore, but I
> >>>think I just grabbed it from another working site. If you like, I could
> >>>zip it up and send it to you.
> >>>
> >>>The site uses blobs (all sub_type text) in many places, so maybe
> >>>older/other versions don't support this as well.
> >>>
> >>>Bob Corriher
> >>>CTO
> >>>P-Wave Inc.
> >>>
> >>>Philip Kilner wrote:
> >>>
> >>>
> >>>
> >>>>Hi Ashley,
> >>>>
> >>>>Can't help you on the blob front...
> >>>>
> >>>>Ashley Lloyd wrote:
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>>I've had trouble installing kinterbase (it complains about LDAP..?),
so
> >>>>>at the moment I use gvib. I've pencilled in quite a bit of time today
to
> >>>>>try to get kinterbase installed.
> >>>>>Unfortunately I'm on Windows, which I'm guessing contributes to the
> >>>>>installation problems!
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>...but I can confirm that KIinterbaseDA works nicely on Windows - I've
> >>>>been happily using it for some time, and haven't had any issues at all
> >>>>(BTW, I don't use LDAP and KInterbaseDA has never mentioned it!). The
> >>>>only problem I had at install time was getting my head around the
> >>>>distinction between the Python part and the Zope DA part.
> >>>>
> >>>>HTH
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>-- 
> >>>No virus found in this outgoing message.
> >>>Checked by AVG Anti-Virus.
> >>>Version: 7.0.338 / Virus Database: 267.9.8/61 - Release Date: 8/1/2005
> >>>
> >>>
> >>>
> >>>
> >
>
  ------------------------------------------------------------------------
> >     No virus found in this outgoing message.
> >     Checked by AVG Anti-Virus.
> >     Version: 7.0.338 / Virus Database: 267.9.8/61 - Release Date:
8/1/2005
> >
>
>
>
> -- 
> No virus found in this outgoing message.
> Checked by AVG Anti-Virus.
> Version: 7.0.338 / Virus Database: 267.9.8/61 - Release Date: 8/1/2005
>
>
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to