Hmm... not sure what causes this (did you upgrade ZODB versions?) but
you may try:

1. Shut down Zope (or ZEO if you use that).

2. find your Data.fs file

3. Delete the file beside it named Data.fs.index

4. Restart Zope (or ZEO).

See if the error goes away..  FileStorage builds an index of oid to file
position in this index.  It's transient, and will be rebuilt when the
process is restarted.

- C


On Mon, 2005-08-08 at 11:11 -0300, David Pratt wrote:
> I just began receiving this error this morning in one of my event logs 
> on start up. It looks serious.
> 
> 2005-08-08T08:49:26 WARNING ZODB.FileStorage Failed to load database 
> index: exceptions.AttributeError: type object 'BTrees._fsBTree.fsBTree' 
> has no attribute '__basicnew__'
> 
> Can someone advise a course of action and what may have happened to 
> generate such an error. I use CMFBTreeFolders extensively in CMF. Many 
> thanks.
> 
> Regards,
> David
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists - 
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope-dev )
> 

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to