follow-up from my post earlier today:

I ran fsrecover.py on a copy of my Data.fs.  It found no errors, but then when 
it attempted to pack the file, it raised an unpickleable error, with this 
traceback:

Traceback (most recent call last):
  File "fsrecover.py", line 374, in ?
    main()
  File "fsrecover.py", line 243, in main
    recover(inp, outp, verbose, partial, force, pack)
  File "fsrecover.py", line 369, in recover
    ofs.pack(pack, referencesf)
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/FileStorage.py", line 1582, 
in pack
    opos = p.pack()
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/fspack.py", line 700, in 
pack
    self.gc.findReachable()
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/fspack.py", line 456, in 
findReachable
    self.findReachableAtPacktime([z64])
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/fspack.py", line 531, in 
findReachableAtPacktime
    todo.extend(self.findrefs(pos))
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/fspack.py", line 604, in 
findrefs
    return referencesf(self._file.read(dh.plen))
  File "/export1/Zope-2.7.5-final/lib/python/ZODB/referencesf.py", line 38, in 
referencesf
    raise ValueError, 'Error unpickling, %s' % p
ValueError: Error unpickling, and the rest is presumably the pickle.

I receive this same error when trying to pack using the ZMI.  Any idea what's 
going on?

Thanks for the help,
Andy

On Monday 08 August 2005 08:15 am, Andy Altepeter wrote:
> Hi there,
>
> There seems to be a problem with my ZCatalog, and it seems to be getting
> worse as time goes by.  When my CatalogPathAware objects unindex
> themselves, sometimes I get an attribute error like:
>
> AttributeError: 'str' object has no attribute 'append'
>
> Traceback (innermost last):
>   Module ZPublisher.Publish, line 101, in publish
>   Module ZPublisher.mapply, line 88, in mapply
>   Module ZPublisher.Publish, line 39, in call_object
>   Module Products.FileSystemSite.FSPythonScript, line 104, in __call__
>   Module Shared.DC.Scripts.Bindings, line 306, in __call__
>   Module Shared.DC.Scripts.Bindings, line 343, in _bindAndExec
>   Module Products.FileSystemSite.FSPythonScript, line 160, in _exec
>   Module None, line 33, in tab_status_approve
>    - <FSPythonScript
> at /silva/service_views/Silva/edit/VersionedContent/tab_status_approve used
> for /silva/service_views/SilvaDocument/edit/VersionedContent/Document>
>    - Line 33
>   Module Products.Silva.Versioning, line 125, in approve_version
>   Module Products.Silva.Versioning, line 512, in _update_publication_status
>   Module Products.Silva.VersionedContent, line 334, in _unindex_version
>   Module Products.Silva.Version, line 191, in unindex_object
>   Module Products.ZCatalog.ZCatalog, line 558, in uncatalog_object
>   Module Products.ZCatalog.Catalog, line 411, in uncatalogObject
>   Module Products.ZCTextIndex.ZCTextIndex, line 181, in unindex_object
>   Module Products.ZCTextIndex.OkapiIndex, line 68, in unindex_doc
>   Module Products.ZCTextIndex.BaseIndex, line 176, in unindex_doc
>   Module Products.ZCTextIndex.BaseIndex, line 303, in _del_wordinfo
>   Module ZODB.Connection, line 562, in setstate
>   Module ZODB.Connection, line 601, in _set_ghost_state
> AttributeError: 'str' object has no attribute 'append'
>
> In the logfile, the last line of code is shown in the traceback:
>   File "/export1/Zope-2.7.2-0/lib/python/ZODB/Connection.py", line 601, in
> _set_ghost_state
>     state = unpickler.load()
>
> Perhaps this is a ZEO issue.  I'm using Zope-2.7.2-0 with ZEO.  Both the
> zeo server and the client are on the same box.  The zeo logfile reports no
> errors when this occurs.
>
> Any ideas why this may be happening?
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope-dev )
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to