----- Original Message ----- From: "Scott Mann" <[EMAIL PROTECTED]>
Sorry in advance for this newbie question. I've searched the archives and while I have learned a few things and tried a few things, I still have the same problem.

I am attempting to add the external python module "nb_fetch" Doing so returns the error message:

"Module /data/zope/testbed/initialzope/Extensions/nb_fetch.py, line 3, in ?

            ImportError: No module named nb_parse"

where nb_parse is imported by nb_fetch. I have tried adding __init__.py into the Extensions directory. I have also made a number of attempts at adding directories to the PYTHONPATH, but no success. I have even put the imported modules (nb_parse, etc) into the lib/python subdirectory of the zope directory. Also, I restart zope every time I make a change. Any ideas?

Zope is unable to add the external method because there is a python error ('No module named nb_parse') which stops zope from loading the external method. Two possible fixes:

1) set your path to include the directory where nb_parse.py lives.
   import sys

Also, make sure the group/ownership of the directory and python routine files allow zope to access them.

2) try 'hardcoding' the nb_parse routine within nb_fetch.py. If this works, then your problem is definitely related to pythonpath not being set up (or zope can't access the directories/files in the path).



Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to