Sorry, I didn't make myself clear .. I have the full backup of the original 
Data.fs and then the incremental "deltafs"  files, from which I tried to 
recover Data.fs:

2004-11-19-07-32-58.fs
2005-01-04-07-00-53.deltafs
2005-01-01-07-00-57.deltafs
...
2005-08-26-06-01-25.deltafs
2005-08-27-06-01-29.deltafs
2005-08-30-06-01-28.deltafs


-----Original Message-----
From: Tino Wildenhain [mailto:[EMAIL PROTECTED] 
Sent: Wednesday, August 31, 2005 2:18 AM
To: Paul Sue
Cc: zope@zope.org
Subject: Re: [Zope] HELP!! Data.fs corrupted

Paul Sue schrieb:
> Hi,
>  
> Our server crashed and wouldn't boot up.  Fortunately, we had backups of of 
> Data.fs on another server .. so I installed Zope 2./7.4/Plone 2.0.5 on 
> another server and used repozo to try to restore Data.fs:
>  
> ./repozo.py -Rv -r /temp/recover -o Data.fs
> 
> However, when I start up Zope, I get:
>  
> 2005-08-31T01:20:21 PANIC(300) ZODB FS FS21 ERROR: 
> /home/zope/ssoi/var/Data.fs data record exceeds transaction record at 
> 54956706 ....
> ....
> ZODB.FileStorage.CorruptedTransactionError: 
> /home/zope/ssoi/var/Data.fs data record exceeds transaction record at 
> 54956706
> 
> I've tried restoring from a few days ago using the "-D" option, but I get the 
> same problem.
> 
> Am I totally hooped or is there some way to recover???

Err. I dont think you need repozo to use your backup Data.fs.
You should just be able to put (a regular file copy) of your backed up Data.fs 
in place.
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to