I am using Zope 2.8.1 and adding an xslt method produces the following
error:
Module ZPublisher.Publish, line 113, in publish
      * Module ZPublisher.mapply, line 88, in mapply
      * Module ZPublisher.Publish, line 40, in call_object
      * Module Shared.DC.Scripts.Bindings, line 311, in __call__
      * Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
      * Module Products.PageTemplates.PageTemplateFile, line 110, in
        _exec
      * Module Products.PageTemplates.PageTemplate, line 102, in
        pt_render
        <PageTemplateFile at /create>
      * Module TAL.TALInterpreter, line 206, in __call__
      * Module TAL.TALInterpreter, line 250, in interpret
      * Module TAL.TALInterpreter, line 649, in do_loop_tal
      * Module Products.PageTemplates.TALES, line 206, in setRepeat
      * Module Products.PageTemplates.TALES, line 221, in evaluate
        URL: create
        Line 70, Column 6
        Expression: standard:'here/availableProcessors'
        Names:
        {'container': <App.ProductContext.__FactoryDispatcher__ object at 
0x414b478c>,
         'context': <App.ProductContext.__FactoryDispatcher__ object at 
0x414b478c>,
         'default': <Products.PageTemplates.TALES.Default instance at 
0x40be970c>,
         'here': <App.ProductContext.__FactoryDispatcher__ object at 
0x414b478c>,
         'loop': <Products.PageTemplates.TALES.SafeMapping object at 
0x414c13ec>,
         'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter 
instance at 0x40bfa5ac>,
         'nothing': None,
         'options': {'args': ()},
         'repeat': <Products.PageTemplates.TALES.SafeMapping object at 
0x414c13ec>,
         'request': <HTTPRequest, 
URL=http://localhost:8080/manage_addProduct/ZopeXMLMethods/create>,
         'root': <Application at >,
         'template': <PageTemplateFile at /create>,
         'traverse_subpath': [],
         'user': garry}
      * Module Products.PageTemplates.Expressions, line 183, in __call__
      * Module Products.PageTemplates.Expressions, line 178, in _eval
      * Module Products.PageTemplates.Expressions, line 85, in render
TypeError: unbound method availableProcessors() must be called with
XSLTMethod instance as first argument (got nothing instead)

I have a Zope 2.7 on the same machine where xslt methods works fine.
Does anyone know what could be wrong here?
regards
Garry

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to