On Fri, Sep 23, 2005 at 12:39:31PM +0100, Peter Bengtsson wrote:
> RESULT:
> -------------------------------------------
> Welcome to testprod
> {'args': (<TestProd at /test/testprod used for /test/testprod>,
> <HTTPRequest, URL=http://localhost:8080/test/testprod/test_testprod>),
> 'something': 'blah'}
> 0
> /test/testprod
> --------------------------------------------
> http://www.peterbe.com/test/TestProd.tgz
> So it works just fine in Zope 2.8.0
> I suspect that the code you paste was idented wrong because the def
> testit() function looked like it was part of the __init__ function.

Yes, the paste was wrong, but there was more than that, I had my editor
slightly misconfigured, which meant that the testit method was done with
tab-indention and the rest of the file with space-indention. After I
fixed that, it worked correctly and "something" shows up in options. I
am absolutely stumped by why an indention problem can cause such a weird
bug. I would have expected Zope/python to spew out an error telling me
that indention was fucked up. To just silently make things not work is
definitely not nice.

Anyway, thank you so much for your help!

-- 
Anders
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GCS/O d--@ s:+ a-- C++ UL+++$ P++ L+++ E- W+ N(+) o K? w O-- M- V
PS+ PE@ Y+ PGP+ t 5 X R+ tv+ b++ DI+++ D+ G e- h !r y?
------END GEEK CODE BLOCK------
PGPKey: 
http://random.sks.keyserver.penguin.de:11371/pks/lookup?op=get&search=0xD4DEFED0
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to