Hooray, new stable releases are always a happy day :)
Thank you Andreas!

Sadly, I have to report some SNAFUs on zope.org,
so I am cc'ing the zope-web list:

On the "Download Zope" page, the latest stable version is still listed
as 2.8.1.   http://www.zope.org/Products/

Also from the main download page, the link labelled
"Our entire collection of zope releases is here"
pointing to http://www.zope.org/Products/Zope/swpackage_releases
requires you to be logged in.  Anonymous can't view that page.
(And I get "insufficient privileges" when I am logged in.)

The same authorization problem occurs when clicking on the "zope"
breadcrumb from the 2.8.2 or 2.7.8 release pages, which points to

Also, looking over the release notes, I see that there is one bugfix
that made it into the 2.8 branch and the trunk, thanks to Andreas -
the #1895 fix to test.py.
But the fix does not seem to have been noted in CHANGES.txt on the
2.8 branch or the trunk.  It *is* in the 2.7.8 CHANGES.txt because I
made sure to do that when I made the same fix on the 2.7 branch.
If there are no objections, I will modify CHANGES.txt on the 2.8 branch
and the trunk.

Thanks again!


Andreas Jung said:
> Hi all,
> on behalf of Zope Corporation and the Zope community I am pleased to
> announce the release of Zope 2.8.2.  You can download Zope 2.8.2 from
>       http://www.zope.org/Products/Zope/2.8.2/
> Some new features of Zope 2.8:
>    - ZODB 3.4 with MVCC (multi version concurrency control) support.
>      MVCC solves nearly every problem with ZODB read-conflict errors
> which is very important for high-traffic Zope sites.
>    - Extension Classes were rewritten as Python new-style classes making
>      all features of Python new-style classes available in Zope
>      objects. This includes support for cyclic garbage collection.
>    - Integration of Zope 3 technologies through Five (see
> http://codespeak.net/z3/five/)
> For more information on what is new in this release, see the
> CHANGES.txt files for the release:
>   http://www.zope.org/Products/Zope/2.8.2/CHANGES.txt
> See also:
>   http://www.zope.org/Wikis/DevSite/Projects/Zope2.8/OverView
> Please bring all the bugs you have found to the Zope bugtracker:
>    http://collector.zope.org/Zope":http://collector.zope.org/Zope
> For more information on the available Zope releases, guidance for
> selecting the right distribution and installation instructions, please
> see:
>    http://www.plope.com/Books/2_7Edition/InstallingZope.stx
> Please also keep in mind that Zope 2.8.2 requires Python 2.3.5. Zope
> 2.8.2 is not certified for any Python 2.4.x versions. So using Python
> 2.4 is  neither recommended nor supported and any related questions or
> problems are  likely to be ignored until 2.4 is an officially supported
> Python version  for Zope.
> --
> Andreas Jung    (andreas at zopyx dot com)

Paul Winkler

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to