Zope 2.8.1

In Plone 2.1.1, when I try to access a page Anonymous does not have
permission to see, it redirects to a login. While doing so, it sets a
came_from variable with the URL I'm trying to access. It sets an ugly

http://my.domain.org/VirtualHostBase/http/my.domain.org:80/contentPages

which does not work. Plone folks suspected this was a Zope problem.

When Plone sets the came_from, it draws on the REQUEST variable. It
first looks to see if there is a VIRTUAL_URL in the REQUEST variable,
but it doesn't find one. I'm wondering if CookieCrumbler is supposed
to set VIRTUAL_URL given that there's a VHM installed and doesn't?

Peace,
George



Peace,
George



On 11/8/05, Chris Withers <[EMAIL PROTECTED]> wrote:
> George Lee wrote:
> > On my Plone site, in CookieCrumbler.py, VIRTUAL_URL is not found in
> > the request variable even though I have a Virtual Host Monster. This
> > means that when logging in, the "came_from" URL that my site directs
> > to becomes something ugly like
>
> What version of Zope are you using?
>
> Why do you think VIRTUAL_URL should be there?
>
> cheers,
>
> Chris
>
> --
> Simplistix - Content Management, Zope & Python Consulting
>             - http://www.simplistix.co.uk
>
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to