Dear People,

I running Apache 2.0 and Zope 2.7 on Debian Sarge. I've configured a zope (Plone) instance located /var/lib/zope2.7/instance/dulci.

This can be accessed via http://machine_address:9673/dulci. 9673 is the point on which Zope runs on Debian.

I'm trying to configure Apache so that all requests of the form

http://machine_address/plone are sent to

https://machine_address:9673/dulci

and that the urls returned by Plone are consistent.

I added the following lines to my Apache config, representing my best guess as to how this should work. The rewriting seems to work, since when I go to

http://machine_address/plone

the log says

[Wed Nov 09 03:30:26 2005] [error] [client ...] client denied by server configuration: proxy:http://127.0.0.1:9673/VirtualHostBase/https/machine_address:443/dulci/VirtualHostRoot/_vh_plone

However, something must be broken.

This seems to be a relatively straighforward matter, but I've already
spent a substantial amount of time on it, so I'd be obliged if someone
can point out if I am missing something obvious, as I probably am.

Please cc me on any reply. Thanks in advance.

********************************************************************
NameVirtualHost *
<VirtualHost *>
[...]

 <IfModule mod_proxy.c>
      ProxyVia On
  </IfModule>

  <IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteRule ^/plone(/.*)?$ 
http://127.0.0.1:9673/VirtualHostBase/https/%{HTTP_HOST}:443/dulci/VirtualHostRoot/_vh_plone$1
 [L,P]
  </IfModule>

</VirtualHost> *******************************************************************

                                                            Faheem.
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to