I am trying to get an old, old product to work in 2.8.4 and I am getting the following error:

Traceback (innermost last):
  Module ZPublisher.Publish, line 113, in publish
  Module ZPublisher.mapply, line 88, in mapply
  Module ZPublisher.Publish, line 40, in call_object
  Module Shared.DC.Scripts.Bindings, line 311, in __call__
  Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  Module App.special_dtml, line 175, in _exec
  Module DocumentTemplate.DT_Let, line 76, in render
  Module DocumentTemplate.DT_In, line 643, in renderwob
  Module DocumentTemplate.DT_In, line 771, in sort_sequence
  Module ZODB.Connection, line 704, in setstate
  Module ZODB.Connection, line 760, in _setstate
  Module ZODB.serialize, line 495, in setGhostState
  Module ZODB.serialize, line 488, in getState
  Module ZODB.serialize, line 399, in _persistent_load
  Module ZODB.serialize, line 372, in _get_class
  Module Zope2.App.ClassFactory, line 29, in ClassFactory
  Module OFS.Uninstalled, line 61, in Broken
  File "<string>", line 1

class <class 'ZDTopic_ZPropertySheetsClass'>(BrokenClass): ' '; __module__=None

          ^

SyntaxError: invalid syntax

I know, that it has something to do with the new extension class, but I can't seem to find any documentation on the new classes, how to write them or how to convert old classes?

Any pointers?

Jake

http://www.ZopeZone.com
"Zoping for the rest of us"



_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to