Jake wrote at 2005-11-12 12:35 -0500:
>I am trying to get an old, old product to work in 2.8.4 and I am  
>getting the following error:
> ...
>   Module Zope2.App.ClassFactory, line 29, in ClassFactory
>   Module OFS.Uninstalled, line 61, in Broken
>   File "<string>", line 1
>     class <class 'ZDTopic_ZPropertySheetsClass'>(BrokenClass): ' ';  
>           ^
>SyntaxError: invalid syntax

Looks as if your class contains some feature no longer supported
by Python.

I would attack this problem as follows:

  *  identify the problematic feature (by extracting the string
     above which exhibits the SyntaxError

  *  find a new way how to spell this

  *  fix the storage file by means of a text editor
     (be careful!: operate on a copy; ensure that the total size
     does not change.

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to