Hash: SHA1

Weiers Coetser wrote:
> Hi
> I wonder if anybody could tell me what I am doing wrong. I installed
> zope 2.8, and plone 2.1 via synaptic.
> I also installed plone-site via synaptic. (When I installed this I was
> promted for a username and password)
> Now when I access: http://localhost:8081, I get a quickstart screen.
> When I click on the link to the management interface
> (http://localhost:8081/manage) I am promted for user name and password.
> It does not accept the username and password that I typed when setting
> up plone-site.
> I've been googling, and at one place there was an explanation that zope
> sets up an inituser file with a username and password. I found such a
> file under /var/lib/zope2.8/instance/plone-site/  with the following
> information in it:
> admin:{SHA}JPpU/BsXGIcv7LQrwgMiOS25PB4=
> I've tried to use this in various ways:  username: admin
> password: {SHA}JPpU/BsXGIcv7LQrwgMiOS25PB4=
> or username: {SHA}JPpU  password: BsXGIcv7LQrwgMiOS25PB4=
> That did not work.
> I tried to create a new inituser account using the following command
> [EMAIL PROTECTED]:/usr/lib/zope2.8/bin$ sudo python zpasswd.py inituser
> and then got the following feedback:
> The programme asked me for a username and a password, to repeat the
> password. I also selected SHA as a mode of encrypting the password, and
> left the domain restrictions blank.
> Unfortunately when I try to connect to (http://localhost:8081/manage), I
> still get the same problem. It won't accept my password. I tried to look
> for other inituser files on my computer, but I do not see any.
> ----> I am really stuck. I don't know how to get plone or zope to work
> on my computer.
> Please help. If you help me, I promise that I will write the details
> into a wiki somewhere.

The 'inituser' file is consumed when Zope starts;  if you still see the
file on the filesystem, then Zope isn't running from the directory where
you think it is, or else doesn't have access to remove the file.

You can create an 'access' file in the instance home (looks like
'/var/lib/zope2.8/plone-site' in your case), with an "emergency user" ID
and password;  you can even leave the password in plain text while
testing, e.g.:

  $ cat /var/lib/zope2.8/plone-site/access

You should then be able to log in as that user after restarting Zope;
that user has limited powers, mostly involving creating "normal" users
and setting up user folders.

- --
Tres Seaver          +1 202-558-7113          [EMAIL PROTECTED]
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to