On 11/29/05, Philipp von Weitershausen <[EMAIL PROTECTED]> wrote:
> We could deprecate DateTime now to warn people about that. But then
> their product would only either work with Zope <2.12 or with Zope >2.12
> (depending on whether it still expects the DateTime API or the
> datetime.datetime API); it would not with both versions. That's a harsh
> upgrade plan and it would probably take ages before people would adopt
> Zope 2.12.

I agree, official deprecation and warnings should only happen when we
have a real backwards compatibility and transition-path. Which would
include what you call a "frankendatetime". :-)

Which, as I understand it, is what Jürgen Herrman wanted to create...

--
Lennart Regebro, Nuxeo     http://www.nuxeo.com/
CPS Content Management     http://www.cps-project.org/
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to