I found the source of my problem uploading a large file to ZODB over DAV and an a workaround that shouldn't have worked but worked. For those who are interested:

For completeness:

 >I would like to put a 120MB file into ZODB and it is constantly failing.

But you should have learned that you cannot simply say "is failing"
but must describe precisely (error information, traceback) *how*
it is failing...

Correct Dieter, I was vague but it indeed would progress and then fail. Goliath, a mac web dav client, would report "Unknown connection error" and the Finder would report "... cannot be completed... one or more required items not found (error code -43) I apologize that I am not familiar with Zope's traceback.

Thank you to Tino for providing a script to copy files into ZODB. This solves a few other issues.

So. I knew to watch my /tmp directory and it was not being used. It turns out that Python (presumably, not Zope) was using /var/tmp (over RAM, given that large-file-threshold in zope.conf was lower than 120MB).

I linked /var/tmp to /tmp and oddly it started using /usr/??? but at least it worked because there was more than 120MB available there. I am not quite sure where it ended up putting it. (seemingly not /var in the zope instance)

The solution appears to be that python can use the TMPDIR variable to specify where tmp should default to (reportedly it will try various locations) but, I am not clear how I can add this to Zope's rc script to declare it. I tried it as simply setting the environment variable "set TMPDIR=/tmp" but that gave warnings about the startup logic.

1. Should TMPDIR work?
2. Where should I declare it when using rc scripts?
3. Any chance zope.conf can use it?



Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to