Hi Folks.
I have an existing (and working) Zope install, but I'm trying to get modern here... I'm having trouble getting Zope 2.8.4 to make properly - keeps complaining "operation not permitted" when copying a file from the zope directory to the build directory.

Like so:
"/usr/local/bin/python" "<myhomedirectory>/Zope-2.8.4-final/setup.py" \
build --build-base="<myhomedirectory>/Zope-2.8.4-final/ build-base/python-2.4" --build-lib="<myhomedirectory>/Zope-2.8.4- final/build-base/python-2.4/build-lib" --build- scripts="<myhomedirectory>/Zope-2.8.4-final/build-base/python-2.4/ build-scripts" --build-temp="<myhomedirectory>/Zope-2.8.4-final/build- base/python-2.4/build-temp"
running build
running build_py
copying zope/component/tests/__init__.py -> <myhomedirectory>/ Zope-2.8.4-final/build-base/python-2.4/build-lib/zope/component/tests error:<myhomedirectory>/Zope-2.8.4-final/build-base/python-2.4/build- lib/zope/component/tests/__init__.py: Operation not permitted
make: *** [build] Error 1

Obviously I've substituted <myhomedirectory> for the actual path.
This error is what I get if I run make as root - if I run as a user, I get "Permission denied".

Any idea what's hanging this up?


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to