On Dec 6, 2005, at 3:02 PM, Dieter Maurer wrote:

Sam Moore wrote at 2005-12-6 10:41 -0500:
...
copying zope/component/tests/__init__.py -> <myhomedirectory>/
Zope-2.8.4-final/build-base/python-2.4/build-lib/zope/component/tests
error:<myhomedirectory>/Zope-2.8.4-final/build-base/python-2.4/build-
lib/zope/component/tests/__init__.py: Operation not permitted

Apparently, copying "zope/component/tests/__init__.py"
to "<myhomedirectory>/>Zope-2.8.4-final/build-base/python-2.4/build- lib/zope/component/tests/__init__.py"
fails.

Well no, actually - the file gets copied! i checked.
But make stops at that point.


Obviously I've substituted <myhomedirectory> for the actual path.
This error is what I get if I run make as root - if I run as a user,
I get "Permission denied".

Is "<myhomedirectory>" an NFS mount?
Then, there are probably special restrictions for "root" use.

No, it's local.


Does the (non root) user have write permissions on "<myhomedirectory>"?

yes, it's that user's own directory. I chown'ed everything in it to make sure the user was the owner, and got similar results (on a different file name, but same scenario).



--
Dieter


_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to