[Chris Wilton]
> Whoops. Sorry.
> Error log tells me it's a 'no space left on device' error:
> 2005-12-08T19:33:30 ERROR(200) SiteError
> http://ekhidna.biocenter.helsinki.fi/dali/downloads/180M.tar/index_html
> Traceback (most recent call last):
>  File "/data/backup/Zope-2.7.0/lib/python/ZPublisher/Publish.py", line 100, 
> in publish
>    request, bind=1)
>  File "/data/backup/Zope-2.7.0/lib/python/ZPublisher/mapply.py", line 88, in 
> mapply
>    if debug is not None: return debug(object,args,context)
>  File "/data/backup/Zope-2.7.0/lib/python/ZPublisher/Publish.py", line 40, in 
> call_object
>    result=apply(object,args) # Type s<cr> to step into published object.
>  File "/data/backup/Zope-2.7.0/lib/python/OFS/Image.py", line 384, in 
> index_html
>    RESPONSE.write(data.data)
>  File "/data/backup/Zope-2.7.0/lib/python/ZServer/HTTPResponse.py", line 190, 
> in write
>    t.write(data)
> IOError: [Errno 28] No space left on device
> I assume this means there's a max cache size set somewhere. There's
> plenty of room left on our fs (hundreds of GB) so Zope isn't being
> allowed to use it at the moment. I'm asuming this is a Zope rather
> than local filesystem issue, but maybe I'm wrong; if it is a Zope
> issue, how I can increase standard cache size? We're not using a cache
> manager, yet...

None of the above ;-)  It's most likely that your temp directory is
mounted on a small partition.  Trying setting the envar TMPDIR to
point at a directory on "a large" partition before starting Zope. 
That is, you're not running into a cache size problem, you're running
into that Zope is creating a large temp file on a partition without
enough space to hold it.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to