I have no idea what the original symptom or situation was, so
I can't really comment.  I'll note, however, that the error
refered to in Pascal's reply results from a wart in Python's
type-definition protocols that I thought I had fixed, but maybe
I proposed fixing it and didn't get around to it. :(

More specific would be helpful. Is a custom C type involved here?


Tres Seaver wrote:
Hash: SHA1

Pascal Peregrina wrote:

Ok, in case anyone is interested, this nasty code change made it :

In Zope-2.8.4-final/lib/python/ZODB/serialize.py:

Change :
       return klass.__new__(klass, *args)

To :
           result=klass.__new__(klass, *args)
       except TypeError:
           result=Persistent.__new__(klass, *args)

       return result

I think Jim is the only one who could explain what you see.  I can't
even find the place in the code which generates that error:

$ find . -name "*.py" -o -name "*.c" | xargs grep "is not safe"
./RestrictedPython/RCompile.py:    The UNPACK_SEQUENCE opcode is not
safe because it extracts
./zope/security/untrustedpython/builtins.py:    # It's better to say
what is safe than it say what is not safe
./ZODB/tests/testmvcc.py:It is not safe, however, to read the current
revision of "a" because


-----Message d'origine-----
De : [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] De la part de Pascal Peregrina
Envoyé : jeudi 15 décembre 2005 12:51
Objet : RE: [Zope] Zope 2.8.4+Latest cygwin installation

Ok, just found it has already been reported several months ago, even with python 2.3.x: http://www.zope.org/Collectors/Zope/1725

Does someone know of any kind of temporary workaround for this ?

Thanks !


-----Message d'origine-----
De : [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] De la part de Pascal Peregrina
Envoyé : jeudi 15 décembre 2005 12:25
Objet : [Zope] Zope 2.8.4+Latest cygwin installation


I would like to know if anyone has been able to compile and run Zope
2.8.4 with Cygwin.

I just installed cygwin with latest stable packages.

I compiled python 2.4.2 (I know, not the supported version, so I am
about to try 2.3.5 now)
I had issues with the socket module, and from google I applied a
workaround that worked fine :
in Modules/socketmodule.c
Change :
#if defined(__sgi) && !defined(INET_ADDRSTRLEN)
To :
/*#if defined(__sgi) && !defined(INET_ADDRSTRLEN)*/

I made several python tests and all looks fine.

Then I compiled Zope 2.8.4 without any issue.

But when I run it, I get this error:

Site Error
An error was encountered while publishing this resource.

Sorry, a site error occurred.

Traceback (innermost last): Module ZPublisher.Publish, line 187, in publish_module_standard Module Products.Localizer, line 58, in new_publish Module ZPublisher.Publish, line 144, in publish Module Zope2.App.startup, line 174, in zpublisher_exception_hook Module App.ZApplication, line 60, in __bobo_traverse__ Module UserDict, line 17, in __getitem__ Module ZODB.Connection, line 704, in setstate Module ZODB.Connection, line 760, in _setstate Module ZODB.serialize, line 495, in setGhostState Module ZODB.serialize, line 488, in getState Module ZODB.serialize, line 436, in _persistent_load Module ZODB.Connection, line 208, in get Module ZODB.serialize, line 482, in getGhost TypeError: Acquirer.__new__(Application) is not safe, use

Does anyone know what I can do ?

Thanks a lot.

- --
Tres Seaver          +1 202-558-7113          [EMAIL PROTECTED]
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to