Not that I am any real guru on this, however, I am still learning myself, my
2c worth....

The error output suggests that Zope is installed on a network share of some
sort ...

line 24, in ?

Are the permissions or effective user correct for the appropriate
filesystems and files.?

If you installed the binaries as root, but are running Zope as another user,
you will need to assign either that effective user to the root group, or
potentially less hazardous, security wise, assign the correct effective user
group rights to the filesystem area, including the network share.

If you have not assigned an effective user, or ran mkzopeinstance as root,
then you may see these type of errors when trying to run Zope as another
user without the correct permissions. Or when running as root, when
effective user permissions are assigned elsewhere.


-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Qass
Sent: Thursday, December 15, 2005 5:13 AM
Subject: [Zope] zopectl or runzope just won't start zope


I'm new to zope and yesterday installed zope 2.8.4 on a linux system running
python 2.3.5 Having followed installation instructions I got to the point of
'zopectl start' and got the following error message while trying both
'runzope' and 'zopectl'.

I've tried installing different versions of Zope and get the same error
(error absent with Zope 3). At one point, Zope did start (I moved it to a
different port) but when I tried installing Plone in the Products directory
of the zope instance, the 'Plone Site' did not show up in the drop down menu
on the right hand side of the ZMI. Which is why I decided to reinstall and
have been getting errors since. I haven't messed around with the Python
installation at all.

In this latest install I ran 'make instance' intead of 'make install'
just to see if I would get the same error as I did yesterday when I had an
instance of Zope running and I did.

Any help in trying to fix this would be highly appreciated. I've tried
changing PYTHONPATH in the zopectl file but that just leads to more and more

Traceback (most recent call last):
  File "/blah//Zope-2.8.4-final/lib/python/Zope2/Startup/", line 56,
in ?
  File "/blah/Zope-2.8.4-final/lib/python/Zope2/Startup/", line 17, in
    import Zope2.Startup
  File "/blah/Zope-2.8.4-final/lib/python/Zope2/", line 60, in ?
    from import configure
line 24, in ?
    import ZConfig
  File "/blah/Zope-2.8.4-final/lib/python/ZConfig/", line 21, in
    from ZConfig.loader import loadConfig, loadConfigFile
  File "/blah/Zope-2.8.4-final/lib/python/ZConfig/", line 23, in ?
    import ZConfig.datatypes
  File "/blah/Zope-2.8.4-final/lib/python/ZConfig/", line 19, in
    import datetime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 13, in
    from DateTime import DateTime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 21, in
    from datetime import datetime
  File "/blah/Zope-2.8.4-final/lib/python/DateTime/", line 21, in
    from datetime import datetime
ImportError: cannot import name datetime

Thank you very much for your help.

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to