After upgrading our Zope instances from Zope 2.7.2 to 2.8.4 we've noticed
new kind of errors in event.log on one of our servers. Error is as follows:

2005-12-19T07:53:59 ERROR BeforeTraverse Error while invoking hook: "input"
Traceback (most recent call last):
File "/opt/Zope/2.8.4/lib/python/ZPublisher/BeforeTraverse.py", line 144, in __call__
   meth(*(container, request, None)[:args])
AttributeError: __call__

I've looked into BeforeTraverse.py and I see this error is only logged to event.log and is not visible to the users, and it seems to me that it is something with acquisition(?) I need some hints how to find what causes this error - what has changed in 2.8.x and
how to deal with this?
Our application is written in ZODB not in products. There is a folder named 'input' in it,
may it be the problem?

Maciej Wisniowski

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to