David Bear wrote at 2006-1-5 15:55 -0700:
>I installed zope 2.7.4 from FreeBSD packages. Trouble is that I already had
>python 2.4 installed. It appears the package just used that version of
>python since zope says it is using python 2.4.
>I've run in to a few wierd things and would like to get a zope instance a
>little more reliable. I was thinking of just making a copy of my zodb file,
>removing the zope pkgs, then do a source install with python 2.3.
>Is the zodb file plug and play transferrable? Can I just copy the zodb into
>the a new zope instance and go?

Try it. It probably will work but in general you cannot expect
backward compatibility:

  A ZODB storage file contains Python pickles.

  While Python tries hard that newer Python versions understand
  pickles written by older versions, sometime new Python versions
  get addtional pickle codes not understood by older Python versions.
  In such cases, the older Python version may not understand
  pickles written by the newer version.

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to