[Robert Conner]
> Thanks for compiling that and setting up the windows installer.
> However, I don't believe it works. Sorry it took me so long to get
> back to you. I wanted to try installing this on a second computer
> before I wrote back. On both of them it

What is "it"?  Please spell out exactly what you did.  The installer
was tested on Win XP Pro SP2 and worked fine there.  I just downloaded
it again, and had no problems:

- Ran the installer, and accepted all the defaults.

- In particular, accepting all the defaults runs Zope as a Windows service, so
  Zope starts automatically, and the installer brings up the

     Zope Windows Binary Post-Installation QuickStart

  page in a broswer.

- I clicked on "Zope Management Interface" in that, and entered the admin
  password I gave to the installer when it asked for one.

- I was then logged in to the ZMI, in a running Zope 2.8.5.

I have no idea what you did, because you really didn't say ;-)

> starts the cmd window and displays the command called to run,

Sorry, I'm not picturing what you did at all.  Needs more words.

> and then fails to finish the load up or start the server. Possibly it does 
> work
> and both of my systems are configured wrong, but I couldn't get either install
> to run.

So I'll try something else:

- I stopped the Zope service (by using the Windows Services applet).

- Opened a DOS box and cd'ed to the root of the instance home (\Zope-Instance,
  the default created by the installer).

- Typed "bin\runzope" and hit ENTER.  This is exactly what was displayed in
  the console then:


C:\Zope-Instance>"C:\Program Files\Zope-2.8.5-final\bin\python.exe"
"C:\Program Files\Zope-2.8.5-final\lib\python\Zope2\
Startup\run.py" -C "C:\Zope-Instance\etc\zope.conf"

    There isn't more output, and more isn't expected.

- Waited a while ;-), then opened a browser and typed


  in the address bar.

- Once again I was then logged in to the ZMI, in a running Zope 2.8.5.

Or another way (something I'd never do in real life, but I guess some
people do):

- Shut down Zope from the last try.

- Clicked Start -> All Programs -> Zope 2.8.5-final -> Run Zope In Console
  That "should be" the same as typing "bin\runzope" by hand as in the last try,
  and indeed it worked the same way.

Did you try one of those ways?  If so, which one?  If not, what did
you try?  If you tried the third way and the goofy little DOS box
"vanished", try the second way instead.  You may get to see a relevant
error message then.  Also look in your instance's var\log\event.log. 
If you're running as a Windows service, look in the Windows
Application and System event logs too.  One particular problem when
running as a service is that Windows Firewall will _not_ prompt you if
it blocks a socket started from a service.  Instead the service hangs
or dies.

> Also, Zope 2.9 is out, if you had planned to make a Windows binary for
> that also.

At this point it's unclear what will happen for that.  Zope 2.9
switches from Python 2.3.5 to Python 2.4.2, and uses zpkgtools for the
first time to package the distribution.  Consequences include that the
code used to build pre-2.9 Zope Windows installers can't work to build
one for 2.9 too.  An unknown amount of new work is needed there, and
AFAICT nobody is working on it.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to