Hello Zope users !

We are  deploying a Zope on  a customer's server, but  we have regular
freeze (Zope stop  to answer any requests). The  Zope is running Plone
2.1 with some custom products.

Here are all the informations I gathered on the issue:

- Zope version 2.8.4
- Plone version 2.1.1
- Python version 2.3.5
- OS: Debian GNU/Linux, sarge, 2.6.8-smp kernel
- Computer: dual Xeon with 4Gb of memory
- Zope is behind Apache configured as reversed proxy


- The Zope stops to answer incoming http request on regular intervals

- When this happens,  the CPU isn't used mch (about  2% used), and the
  memory isn't full (1Gb used on the 4Gb total)

- Inspecting the Python  process with gdb shows a  normal operation: a
  running  thread, and  others  waiting  in, and  then  after a  while
  (dettaching gdb, waiting a  bit, and reattaching gdb) another thread
  running. The other threads are in:

#0  0x40026d0b in [EMAIL PROTECTED] () from /lib/tls/libpthread.so.0
#1  0x00000004 in ?? ()
#2  0x080d29de in PyThread_acquire_lock (lock=0x87b1e70, waitflag=1)
    at thread_pthread.h:406

- Looking at netstat  shows a few established connections  to the Zope
  process, but not much (2-3 on avergae)

What we tried:

- We tried using ZEO, didn't change anything

- We tried with the default 4 threads, with 10 threads, and with up to
  40 threads, nothing changed

I'm currently out of ideas to  investigate this issue. Does any of you
have an idea of why could this happen ? Or an idea of what I could try
to undersatnd what's happening ? Any idea is dearly welcomed.

Thanks a lot !

Gaël Le Mignot - [EMAIL PROTECTED]
Pilot Systems - 9, rue Desargues - 75011 Paris
Tel : +33 1 44 53 05 55 - http://www.pilotsystems.net
Hébergement Zope et Plone gratuit - http://www.objectis.org
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to