Didn't think of that... and it wont mess with my config.



Håkan Johansson wrote:

On Jan 16, 2006, at 22:52, Jonathan Cyr wrote:

Does the Zope Wiki article on Repozo tell you where to find it, maybe I missed it.  I actually looked for quite a while.  Maybe it just needs to be a little clearer... or maybe I need a smack in the head.

 I didn't have much success anyway, I setup my Zope/ZEO setup using SuSE 9.0's onboard Python and PIL installs, which, at the time, seemed an easy way to reproduce a ZEO client machine over and over. 

 Upon running repozo, it can't find the pieces of Zope/ZODB, it needs to run, and I get an immediate traceback refering to the import of ZODB.   After trying to adjust the pythonpath (wouldn't stick), and trying to drop repozo in the right directory.  I couldn't get it to work.  And, frankly, with everything Zope/Python/PIL working fine, I didn't mess with it very hard, fearing breaking it.

 Using SuSE's YAST installed Python seems to be my mistake... but It made sense at the time, and the right versions and everything... and although it works, upgrading Zope and using repozo are major drawbacks.

 I'll have to build a new box, correctly, and migrate to it.

 In any case, thanks for your time,


I had the same problem with repozo. I "solved" it by modifying the repozo.py file and adding "sys.path.append( PATH/TO/ZOPE/lib/python )" right before the "from ZODB.FileStorage ..." line.
It's not a beautiful fix, but it works.

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Jonathan Cyr

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to