Yellow ppl,

I've instaled Zope 2.9.0 on Fedora 4 using Python 2.4.2 compiled from
source. Everything ok.
I was trying to do exactly the same (Zope 2.9.0 with Python 2.4.2 from
source) in Debian 3.1 and I got the following error:

bsbserv035:/var/zope/inst1/bin# ./runzope
Traceback (most recent call last):
  File "/var/zope/lib/python/Zope2/Startup/", line 56, in ?
  File "/var/zope/lib/python/Zope2/Startup/", line 19, in run
    opts = _setconfig()
  File "/var/zope/lib/python/Zope2/Startup/", line 48, in _setconfig
    opts.realize(doc="Sorry, no option docs yet.")
  File "/var/zope/lib/python/zdaemon/", line 273, in realize
  File "/var/zope/lib/python/zdaemon/", line 321, in load_schema
    self.schema = ZConfig.loadSchema(self.schemafile)
  File "/var/zope/lib/python/ZConfig/", line 31, in loadSchema
    return SchemaLoader().loadURL(url)
  File "/var/zope/lib/python/ZConfig/", line 65, in loadURL
    return self.loadResource(r)
  File "/var/zope/lib/python/ZConfig/", line 159, in loadResource
    schema = ZConfig.schema.parseResource(resource, self)
  File "/var/zope/lib/python/ZConfig/", line 27, in parseResource
    xml.sax.parse(resource.file, parser)
  File "/usr/local/lib/python2.4/xml/sax/", line 33, in parse
  File "/usr/local/lib/python2.4/xml/sax/", line 107, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/local/lib/python2.4/xml/sax/", line 123, in parse
  File "/usr/local/lib/python2.4/xml/sax/", line 207, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/local/lib/python2.4/xml/sax/", line 300, in
    self._cont_handler.startElement(name, AttributesImpl(attrs))
  File "/var/zope/lib/python/ZConfig/", line 99, in startElement
    getattr(self, "start_" + name)(attrs)
  File "/var/zope/lib/python/ZConfig/", line 475, in start_schema
    keytype, valuetype, datatype = self.get_sect_typeinfo(attrs)
  File "/var/zope/lib/python/ZConfig/", line 201, in get_sect_typeinfo
    datatype = self.get_datatype(attrs, "datatype", "null", base)
  File "/var/zope/lib/python/ZConfig/", line 194, in get_datatype
    return self._registry.get(dtname)
  File "/var/zope/lib/python/ZConfig/", line 398, in get
    t =
  File "/var/zope/lib/python/ZConfig/", line 423, in search
    package = __import__(n, g, g, component)
  File "/var/zope/lib/python/Zope2/Startup/", line 21, in ?
    import OFS.Uninstalled
  File "/var/zope/lib/python/OFS/", line 16, in ?
    import  SimpleItem, Globals, Acquisition
  File "/var/zope/lib/python/OFS/", line 26, in ?
    import AccessControl.Role, AccessControl.Owned, App.Common
  File "/var/zope/lib/python/AccessControl/", line 17, in ?
    from Implementation import setImplementation
  File "/var/zope/lib/python/AccessControl/", line 98, in ?
  File "/var/zope/lib/python/AccessControl/", line
51, in setImplementation
    from AccessControl import ImplC as impl
  File "/var/zope/lib/python/AccessControl/", line 30, in ?
    from ImplPython import RestrictedDTML, SecurityManager, ZopeSecurityPolicy
ImportError: No module named ImplPython

Any1 solved this already???


Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to