Ivan "Rambius" Ivanov wrote:


I am observing a strange problem when trying to use
MKCOL WebDAV method with a specific url. I can
reproduce it with two WebDAV clients: Jakarta
Slides[1] and the command-line client nd[2].
The problem: Invoking MKCOL method against Zope's
WebDAV server with an url ending with "title" fails.
Usind nd I can reproduce it with the following
command: nd -k http://localhost:8280/title (From nd man page -k option sends MKCOL request)

This command fails with
Error: MKCOL failed, `Not Found'

If I change the command to end with anything different
than "title" it works:
nd -k http://localhost:8280/title1
and I can see in ZMI that title1 folder is created.

Some background: I initially noticed this behaviour
Plone (version 2.0.5) under Windows XP while I was
executing a large number of MKCOLs. I tried to reduce
the problem, so I installed on my personal FreeBSD
laptop Zope 2.7.8 for FreeBSD ports. I created a zope
instance and I configured in its zope.conf that http
server runs on 8080 port and webdav server runs on
8280 port.

I checked this problem agains Apache Httpd and mod_dav
and creating such a collection works. This makes me
think that Zope uses title suffix for internal aims.

My question is how I can workaround this problem?



Maybe because 'title' is a common object property and it is getting acquired before the intended one?


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to