Owen,
Just saw your message.  Instead of restarting Zope,
did you try stop and then start.  I've had trouble in
the past with restarting my Zope/Plone sites; not
everything seems to get reinitialized with just a
restart.

Also, I'm not using the versions of Zope/Plone you are
using.  I'm way behind you!!!

Usually, when I see import exceptions, I start doing
grep on the .py files in the product directory where
the error is appearing.  Try grep on partial names of
the module that is not being imported and see what
comes up (on windows, I use UltraEdit's "Find in
Files", which does regular expressions, etc.).

Barry

--- Owen K <wrote:

> Update:
> 
> I have learned how to uncomment configure.zcml by
> removing a matching pair 
> <!-- -->  ; then restarted Zope.
> At this point the traceback looks the same as
> documented below and the 
> install configlet does not appear in Plone 2.1.2
> add/remove products page. 
> There is an error reported on that page:
> 
> TextIndexNG3
> Error Type
>     exceptions.ImportError
> Error Value
>     cannot import name textindexng_globals
> 
> Hmm....
> 
> "Owen K" <[EMAIL PROTECTED]> wrote in message 
> news:[EMAIL PROTECTED]
> > Hi all,
> >
> > I am trying to install TextIndexNG 3.1.5 on
> Windows.
> > I recompiled the pyd files successfully using
> MinGW.
> > However TextIndexNG3 setup fails to find them,
> traceback included below.
> > There are three instructions from the fine manual
> and elsewhere that I am 
> > trying to follow:
> >
> > 1. README says Plone users must remove comments
> from configure.zcml .
> > 2. Release notes say: rebuild *and* reinstall .
> Rebuild works, but 
> > reinstall does not.
> > 3. Barry Drake suggested move the pyd files from
> build dir to TextIndexNG 
> > dir
> >
> > Regarding 1, I am using Plone 2.1.2. but I don't
> recognize anything that 
> > looks like a comment in 3.1.5 version of
> configure.zcml. (But I don't know 
> > how to read that kind of file.)
> >
> > Regarding 2. Build was successful, but reinstall
> fails as follows. Running 
> > "python setup.py install" in 
> >
>
C:\Zope-Instance\Products\TextIndexNG3\extension_modules
> fails with the 
> > same error that started this thread regarding VC6
> mismatch. However Barry 
> > and I have had pyds created by this method working
> successfully with 
> > TextIndexNG2.
> >
> > Regarding 3. The traceback error occurs regardless
> of whether the pyd 
> > files are in any of the following
> > C:\Zope-Instance\Products\TextIndexNG3\
> >
>
C:\Zope-Instance\Products\TextIndexNG3\extension_modules
> >
>
C:\Zope-Instance\Products\TextIndexNG3\extension_modules\zopyx\txng3
> > C:\Zope-Instance\Products\TextIndexNG3\Extensions
> >
> > My setup:
> > python.exe is registered in Windows
> > there is only one python.exe on the machine
> > Zope 2.8.5 new install, includes python 2.3.5
> > Plone 2.1.2
> > TextIndexNG3.1.5 is installed in
> C:\Zope-Instance\Products\TextIndexNG3
> >
> > Any thoughts?
> >
> > Thanks,
> >
> > Owen       ....my event.log for this issue is
> next....
> >
> > Traceback:
> > ------
> > 2006-02-17T15:48:03 ERROR Zope Could not import
> Products.TextIndexNG3
> > Traceback (most recent call last):
> >  File "C:\Program
>
Files\Zope-2.8.5-final\lib\python\OFS\Application.py",
> 
> > line 698, in import_product
> >    product=__import__(pname, global_dict,
> global_dict, silly)
> >  File
>
"C:\Zope-Instance\Products\TextIndexNG3\__init__.py",
> line 20, in ?
> >    import TextIndexNG3
> >  File
>
"C:\Zope-Instance\Products\TextIndexNG3\TextIndexNG3.py",
> line 18, 
> > in ?
> >    from textindexng.index import Index
> >  File
>
"C:\Zope-Instance\Products\TextIndexNG3\src\textindexng\index.py",
> 
> > line 20, in ?
> >    from evaluator import Evaluator
> >  File 
> >
>
"C:\Zope-Instance\Products\TextIndexNG3\src\textindexng\evaluator.py",
> 
> > line 18, in ?
> >    from stemmer import getStemmer
> >  File
>
"C:\Zope-Instance\Products\TextIndexNG3\src\textindexng\stemmer.py",
> 
> > line 11, in ?
> >    from zopyx.txng3 import stemmer
> > ImportError: No module named zopyx.txng3
> > ------
> > [ ... snip ... ]
> > ------
> > 2006-02-17T15:48:05 ERROR Zope Couldn't install
> Five
> > Traceback (most recent call last):
> >  File "C:\Program
>
Files\Zope-2.8.5-final\lib\python\OFS\Application.py",
> 
> > line 775, in install_product
> >    initmethod(context)
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\Products\Five\__init__.py",
> line 29, in 
> > initialize
> >    zcml.load_site()
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\Products\Five\zcml.py",
> line 45, in 
> > load_site
> >    _context = xmlconfig.file(file)
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\xmlconfig.py",
> line 
> > 439, in file
> >    include(context, name, package)
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\xmlconfig.py",
> line 
> > 375, in include
> >    processxmlfile(f, context)
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\xmlconfig.py",
> line 
> > 245, in processxmlfile
> >    parser.parse(src)
> >  File "C:\Program
>
Files\Zope-2.8.5-final\bin\Lib\xml\sax\expatreader.py",
> 
> > line 107, in parse
> >    xmlreader.IncrementalParser.parse(self, source)
> >  File "C:\Program
>
Files\Zope-2.8.5-final\bin\Lib\xml\sax\xmlreader.py",
> 
> > line 123, in parse
> >    self.feed(buffer)
> >  File "C:\Program
>
Files\Zope-2.8.5-final\bin\Lib\xml\sax\expatreader.py",
> 
> > line 207, in feed
> >    self._parser.Parse(data, isFinal)
> >  File "C:\Program
>
Files\Zope-2.8.5-final\bin\Lib\xml\sax\expatreader.py",
> 
> > line 348, in end_element_ns
> >    self._cont_handler.endElementNS(pair, None)
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\xmlconfig.py",
> line 
> > 225, in endElementNS
> >    self.context.end()
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\config.py",
> line 518, 
> > in end
> >    self.stack.pop().finish()
> >  File "C:\Program 
> >
>
Files\Zope-2.8.5-final\lib\python\zope\configuration\config.py",
> line 665, 
> > in finish
> >    actions = self.handler(context, **args)
> 
=== message truncated ===

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to