Hello,

I made a copy of a live Zope-instance behind a webserver to my PC for testing purposes. I just copied the files in 'var' and 'Products' and changed the folders in zopectl. I am also running the same Zope version (2.8.0) as on the remote server and with the same structure:


Root Folder
|_ ...
|_ acl_users (User Folder)
|_ middelen
   |_ acl_users (Remote User Folder)
   |_ ...
|_ ...

When I try to log in to http://localhost:8080/middelen I get a 'TypeError: unpack non-sequence' instead of a login-prompt. Logging in to http://localhost:8080/manage does work.

Below is the entry from the middelen/error_log:

Time    2006/03/02 13:22:49.932 GMT+1
User Name (User Id)     Anonymous User (None)
Request URL     http://localhost:8080/middelen/index_html
Exception Type  TypeError
Exception Value         unpack non-sequence

Traceback (innermost last):

    * Module ZPublisher.Publish, line 104, in publish
    * Module ZPublisher.BaseRequest, line 445, in traverse
* Module Products.RemoteUserFolder.RemoteUserFolder, line 244, in validate

TypeError: unpack non-sequence

REQUEST
form
cookies
lazy items
SESSION <bound method SessionDataManager.getSessionData of <Products.Sessions.SessionDataManager.SessionDataManager object at 0x412b2f2c>>
other
TraversalRequestNameStack       []
URL     'http://localhost:8080/middelen/index_html'
SERVER_URL      'http://localhost:8080'
PUBLISHED       <OFS.DTMLMethod.DTMLMethod object at 0x414f446c>
ACTUAL_URL      'http://localhost:8080/middelen'
URL0    http://localhost:8080/middelen/index_html
URL1    http://localhost:8080/middelen
URL2    http://localhost:8080
BASE0   http://localhost:8080
BASE1   http://localhost:8080
BASE2   http://localhost:8080/middelen
BASE3   http://localhost:8080/middelen/index_html
environ
HTTP_ACCEPT 'text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5'
HTTP_ACCEPT_CHARSET     'ISO-8859-1,utf-8;q=0.7,*;q=0.7'
HTTP_USER_AGENT 'Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)'
SERVER_NAME     '0.0.0.0'
GATEWAY_INTERFACE       'CGI/1.1'
channel.creation_time   1141302169
SERVER_SOFTWARE 'Zope/(Zope 2.8.0-final, python 2.3.5, linux2) ZServer/1.1'
REMOTE_ADDR     '127.0.0.1'
HTTP_ACCEPT_LANGUAGE    'nl,en-us;q=0.7,en;q=0.3'
SCRIPT_NAME     ''
REQUEST_METHOD  'GET'
HTTP_HOST       'localhost:8080'
HTTP_KEEP_ALIVE '300'
SERVER_PORT     '8080'
SERVER_PROTOCOL 'HTTP/1.1'
PATH_TRANSLATED '/middelen'
CONNECTION_TYPE 'keep-alive'
HTTP_ACCEPT_ENCODING    'gzip,deflate'
PATH_INFO       '/middelen'

Does anyone know what the problem might be?

Kind regards,

Leandros van den Berg
The Netherlands
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to