Hello ...

I've been trying to put together a relatively small ZMI based
product.  When I go to distribute it, I click on the "distribution" tab,
select to allow redistribution and then "create distribution archive", as
per the Zope Book.  (And I've also tried this w/o allowing redistribution,
as well as tried this on the toy "Zoo Exhibit" product in the Zope
Book).  When I click on "create distribution archive" I get:

    *  Module ZPublisher.Publish, line 175, in publish_module_standard
    * Module ZPublisher.Publish, line 132, in publish
    * Module ZPublisher.Publish, line 101, in publish
    * Module ZPublisher.mapply, line 88, in mapply
    * Module ZPublisher.Publish, line 39, in call_object
    * Module App.Product, line 489, in index_html
    * Module App.Product, line 200, in _distribution

ImportError: No module named rotor

This also crashes Zope entirely (needs to be restarted).  This is with
Zope 2.7.3 with python 2.4.1.

>From what I've read, the rotor module was deprecated in python 2.3 and
then removed in python 2.4, which would be why I don't have the rotor
module.  One page I found:

Seems to describe exactly the situation I'm having.

My question is what is the appropriate workaround here?  Is this
considered an issue w/ the version of Python I'm using or the version of
Zope?  One piece of advice I read (involving importing rotor but not w/
Zope) was to downgrade to Python 2.3 but I'd prefer not to do that.  If I
upgrade Zope will that remove the dependence on the rotor module?


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to