I have python 2.4.2 installed on freebsd. It is located at /home/webenv/bin/python2.4.

I set my pythonpath to /home/webenv/lib/python2.4

Python works.

Then I downloaded and built zope 3 with make sure to use -with-python and -prefix /home/z3.

I run make then make test and get a lot of :

Error in test testNOK (ZEO.tests.testAuth.PlainTextAuth)
Traceback (most recent call last):
  File "/home/webenv/lib/python2.4/unittest.py", line 270, in run
    self.tearDown()
  File "/home/iddwb/installs/Zope-3.2.0/build/lib.freebsd-4.10-RELEASE-p2-i386-2.4/ZEO/tests/testAuth.py", line 54, in tearDown
    self.__super_tearDown()
  File "/home/iddwb/installs/Zope-3.2.0/build/lib.freebsd-4.10-RELEASE-p2-i386-2.4/ZEO/tests/ConnectionTests.py", line 118, in tearDown
    forker.shutdown_zeo_server(adminaddr)
  File "/home/iddwb/installs/Zope-3.2.0/build/lib.freebsd-4.10-RELEASE-p2-i386-2.4/ZEO/tests/forker.py", line 180, in shutdown_zeo_server
    s.connect(adminaddr)
  File "<string>", line 1, in connect
error: (60, 'Operation timed out')


The errors are all 'operation timed out'.

this happens when I run make test as root as well.

any pointers?

--
David Bear
What's the difference between private knowledge and public knowledge?
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to