Hello,

Thank you for your hints. I successfully compiled python2.3.5 for OS
10.4, as described in Florent Guillaume's blog, but when I try to
compile Zope, I get the same error:

$ ./configure --prefix=/opt/Zope2.8 --with-python=/usr/local/bin/python2.3

Using Python interpreter at /usr/local/bin/python2.3

Configuring Zope installation

  - Zope top-level binary directory will be /opt/Zope2.8.
  - Makefile written.

  Next, run make.

$ make
"/usr/local/bin/python2.3" "/Users/spuhlema/Desktop/Zope-2.8.6-final/setup.py" \
            build
--build-base="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/python-2.3"
--build-lib="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/python-2.3/build-lib"
--build-scripts="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/python-2.3/build-scripts"
--build-temp="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/python-2.3/build-temp"
running build
running build_py
error: package directory
'build/lib/darwin-8/5/2-i386-2/4/zope/app/traversing/ftests' does not
exist
make: *** [build] Error 1

I guess Python doesn't compile equally on PowerPc and Intel.
Any idea?


2006/3/19, Jens Vagelpohl <[EMAIL PROTECTED]>:
> > $ make
> > "/usr/bin/python" "/Users/spuhlema/Desktop/Zope-2.8.6-final/
> > setup.py" \
> >             build
> > --build-base="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/
> > python-2.3"
> > --build-lib="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/
> > python-2.3/build-lib"
> > --build-scripts="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-
> > base/python-2.3/build-scripts"
> > --build-temp="/Users/spuhlema/Desktop/Zope-2.8.6-final/build-base/
> > python-2.3/build-temp"
>
> This line shows you are using the system Python at /usr/bin/python.
> Don't. It's no good at all for compiling anything. Run "configure"
> with the --with-python=/path/to/python flag to use a self-compiled
> Python.
>
> I have never used the Fink Python. It is child's play to compile
> Python yourself (with the exception of Python 2.3.5 on OS X 10.4), so
> that's the way to go. Here's the instructions I work from:
>
> http://www.zope.org/Members/jens/docs/Document.2003-12-27.2431
>
> These are not written for OS X/i386, but I'd be surprised if they
> didn't work on both platforms.
>
> jens
>
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> http://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
>  http://mail.zope.org/mailman/listinfo/zope-announce
>  http://mail.zope.org/mailman/listinfo/zope-dev )
>
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to