Last week I posted this:

>> I've got a site with a couple hundred ExtFile objects. I now need to

>> index the content of the various files (word, pdf, excel, ppt).

>> I see that ExtFile doesn't have a PrincipiaSearchSource method so I

>> created one. It returns self.index_html(). When I go back into my

>> catalog and reindex my PrincipiaSearchSource index (a textindexng

>> index), clicking the "Reindex" button opens the ExtFile I'm trying to

>> index. Is there something more to the process of trying to index

>> ExtFiles with TextIndexNG. I've googled around and tried a few things

>> but either they don't work or I get the same results I've just

>> described. Any ideas?

I've since deleted the PrincipiaSearchSource method from the file. If my catalog has no TextIndexNG indexes, I can use the Find Objects tab to find and catalog ExtFile objects. If I add a TextIndexNG index named "PrincipiaSearchSource" and click either the "Find and Catalog" button under the "Find Objects" tab or the "Update Catalog" button under the "Advanced" tab, they both return the rendered ExtFile (a pdf file in this case) to the browser. I'm not clear as to what is causing this. I don't think it's ExtFile since it doesn't even have a PrincipiaSearchSource method at this point. I haven't tried upgrading to ExtFile 1.5 from the svn trunk yet but I really don't think that's the problem. I'm going to try that next (upgrading to ExtFile 1.5). Does anyone have any ideas about what would cause the ExtFile to launch instead of just get catalogged?



Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to