i am having trouble with running ZopeXMLMethods on zope-2.8.4. Error is:

    *  Module ZPublisher.Publish, line 113, in publish
    * Module ZPublisher.mapply, line 88, in mapply
    * Module ZPublisher.Publish, line 40, in call_object
    * Module Shared.DC.Scripts.Bindings, line 311, in __call__
    * Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    * Module Products.PageTemplates.PageTemplateFile, line 110, in _exec
    * Module Products.PageTemplates.PageTemplate, line 104, in pt_render
      <PageTemplateFile at /scratch/create>
    * Module TAL.TALInterpreter, line 206, in __call__
    * Module TAL.TALInterpreter, line 250, in interpret
    * Module TAL.TALInterpreter, line 651, in do_loop_tal
    * Module Products.PageTemplates.TALES, line 206, in setRepeat
    * Module Products.PageTemplates.TALES, line 221, in evaluate
      URL: create
      Line 70, Column 6
      Expression: standard:'here/availableProcessors'

      {'container': <App.ProductContext.__FactoryDispatcher__ object at
0xb68bb06c>, 'context': <App.ProductContext.__FactoryDispatcher__
0xb68bb06c>object at 0xb68bb06c>,
       'default': <Products.PageTemplates.TALES.Default instance at
0xb721fe8c>, 'here': <App.ProductContext.__FactoryDispatcher__ object
0xb721fe8c>at 0xb68bb06c>,
       'loop': <Products.PageTemplates.TALES.SafeMapping object at
0xb481980c>, 'modules':
0xb481980c>instance at 0xb712402c>,
       'nothing': None,
       'options': {'args': ()},
       'repeat': <Products.PageTemplates.TALES.SafeMapping object at
0xb481980c>, 'request': <HTTPRequest,
       'root': <Application at >,
       'template': <PageTemplateFile at /scratch/create>,
       'traverse_subpath': [],
       'user': z00root}

    * Module Products.PageTemplates.Expressions, line 185, in __call__
    * Module Products.PageTemplates.Expressions, line 180, in _eval
    * Module Products.PageTemplates.Expressions, line 85, in render

It happens when i try to add 'XSLT Method' (as described in short
tutorial provided with the product).

Something similar has already been reported in this thread:

Any way that i can fix this?

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to