Not so long ago I installed Zope-2.9.2 and as I remember it all worked fine. This morning, with Zope-2.9.3 I get this:

bash Zope-2.9.3: make
/usr/local/bin/python install.py -q build
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c: In 
function ‘module_aq_validate’:
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c:2155: 
warning: ‘obj’ may be used uninitialized in this function
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c:2155: 
warning: ‘name’ may be used uninitialized in this function
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c:2155: 
warning: ‘v’ may be used uninitialized in this function
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c:2155: 
warning: ‘inst’ may be used uninitialized in this function
Dependencies/AccessControl-Zope-2.9.3/AccessControl/cAccessControl.c:2155: 
warning: ‘validate’ may be used uninitialized in this function
bash Zope-2.9.3:


Which I thought meant it did not work. This is with Fedora Core 5 and Python 2.4.3. I went through the whole process again (this time specifying the install folder) and did not get any warnings or OK messages:

bash Zope-2.9.3: ./configure /usr/local/Zope-2.9.3
bash Zope-2.9.3: make
/usr/local/bin/python install.py -q build
bash Zope-2.9.3: make install
/usr/local/bin/python install.py -q build
/usr/local/bin/python install.py -q install --skip-build --home "/usr/local/Zope-2.9.3"
bash Zope-2.9.3:

The installation seems to work? Should I worry about the Dependencies messages?

Cliff

Andreas Jung wrote:

From: Andreas Jung <[EMAIL PROTECTED]>

Hi all,

on behalf of Zope Corporation and the Zope community I am pleased to announce the release of Zope 2.9.3.

You can download  it from

 http://www.zope.org/Products/Zope/2.9.3/


Some new features of Zope 2.9:

 - ZODB 3.6

 - Five 1.3

 - integration for Zope 3 events for object creation and deletion

 - Zope 3 i18n integration for page templates


For more information on what is new in this release, see the
CHANGES.txt files for the release:

 http://www.zope.org/Products/Zope/2.9.3/CHANGES.txt


Please bring all the bugs you have found to the Zope bugtracker:

  "http://collector.zope.org/Zope":http://collector.zope.org/Zope

For more information on the available Zope releases, guidance for selecting
the right distribution and installation instructions, please see:

  http://www.plope.com/Books/2_7Edition/InstallingZope.stx


Support Python versions:

 Zope 2.9 requires Python 2.4.3 (Python 2.4.1, 2.4.2 are still acceptable).
 Older Python versions are no longer supported.


Thanks to all being involved in this release.


------------------------------------------------------------------------

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to