That did the trick! (I had created a /apps/zeo1 directory on the server machine, but I did not have a matching directory on the client machine to hold the persistent cache file)

Thanks very much!


----- Original Message ----- From: "Jens Vagelpohl" <[EMAIL PROTECTED]>
To: "[Zope] List Mailing" <>
Sent: Wednesday, May 24, 2006 10:25 AM
Subject: Re: [Zope] zope.conf Zeo question

Hash: SHA1

On 24 May 2006, at 14:16, Jonathan wrote:
When I run zope on the zeo client & check the 'zeo1' database in the ControlPanel I get the following traceback:

Traceback (innermost last):
 Module ZPublisher.Publish, line 106, in publish
 Module ZPublisher.BaseRequest, line 323, in traverse
 Module App.ApplicationManager, line 122, in __bobo_traverse__
 Module App.ApplicationManager, line 113, in __getitem__
 Module Zope2.Startup.datatypes, line 280, in getDatabase
 Module Zope2.Startup.datatypes, line 178, in open
 Module Zope2.Startup.datatypes, line 175, in createDB
 Module ZODB.config, line 97, in open
 Module ZODB.config, line 155, in open
 Module ZEO.ClientStorage, line 312, in __init__
 Module ZEO.cache, line 107, in __init__
 Module ZEO.cache, line 774, in __init__
IOError: [Errno 2] No such file or directory: '/apps/zeo1/var/ zeo1-1.zec' Why is the zeo client looking for '/apps/zeo1/var/zeo1-1.zec'? How do I get the zeo client to point at the zeo-created Data.fs which resides in /apps/zeo1/var on the machine at 2.9.2 is running on the zeo client. Zope is not running on the server (just zeo from the Zope 2.9.2 installation tarball)Any and all help appreciated!Jonathan

It is attempting to create the persistent cache file, which resides in $INSTANCE/var/XXX. Does the path /apps/zeo1/var/ exist and does the user Zope runs as have permissions to write into that directory?


Version: GnuPG v1.4.1 (Darwin)

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to