Thanks Kees, I will check today and I will report if this solves the issue :-).


On 5/31/06, Kees de Brabander <[EMAIL PROTECTED]> wrote:
  <dtml-call "RESPONSE.setHeader('pragma','no-cache')">
  <dtml-call "RESPONSE.setHeader('Expires',(_.DateTime()-1).rfc822())">
or both in the head section of your page will do the trick.

----- Original Message -----
From: "Marco Bizzarri" <[EMAIL PROTECTED]>
To: "Zope Users Mailing List" <>
Sent: Wednesday, May 31, 2006 7:33 AM
Subject: [Zope] Internet Explorer does not follows redirect,while Firefox

> Hi all.
> I don't think this is a specific Zope problem. However, I'm
> experiencing it in a Zope context, and this is why I'm here asking.
> In a custom Zope application, we have a problem with Internet Explorer.
> The application follows a "page -> submit -> redirect -> page" cycle.
> To state more clearly: the page presented to the user can have a link.
> When the user clicks on the link, something is done, and eventually
> the user is redirected to the same page which will display different
> data based on the results of its previous click.
> The problem is that when IE sees that the result page has the same URL
> as the first page  it does not reload the page and instead shows me
> the cached version.
> The problem is not shown with Firefox.
> As far as I can understand, this is an HTTP header issue, but I would
> like to know if anyone already has experienced this problem, and has
> some solution about it.
> Regards
> Marco
> --
> Marco Bizzarri
> _______________________________________________
> Zope maillist  -
> **   No cross posts or HTML encoding!  **
> (Related lists -
> )

Marco Bizzarri
Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to