We have zope installation that uses an Oracle backend to store data
on.  We also have the system setup to do a backup of the database and
Zope Installation everyday.  Everything runs smoothly until it comes
time to start Zope back up.

For some reason whenever the script tries to start Zope back up, it
comes up but with a broken ZOracleDA product.  It complains about not
being able to find the library file called libclntsh.so.9.0.

If I try to start Zope myself from command line right after the script
is done running (actually stop it then start it again) it works and
connects to Oracle fine.

I've tried using "nice" to up the priority level but it doesn't seem
to work.  I also thought that maybe I wasn't giving oracle enough time
to start up so I've tried adding sleep commands to the script, again,
with no luck.

If anyone has any experience in this field or has any suggestions,
please let me know.  This is a quite annoying situation, as this
server is quite important to the company and downtime is a bad thing.

-David
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to