On 8/7/06, James Davies <[EMAIL PROTECTED]> wrote:

Hi. I've been attempting to develop products with Zope 2.9, and am finding
it increasingly difficult and slow to do so as Product refreshing no longer

 Google shows up a few results from mailing lists with somewhat negative
responses (The gist I'm getting is that no-one 'in the know' wants to worry
about fixing it, as they don't see a real need for it).

Yeah, too bad, but making it better is complicated, and it can never
be perfect anyway.

 Another major issue I've discovered is Zope hosting. We reguarly deploy
custom sites on shared zope environments, and having to restart an entire
server just to update one product severely breaks our uptime guarentee.

You mean you can't allow the server even to be down for the less than
a minute it takes to restart it? I would honestly be very interested
in knowing what kind of systems you run that has that sort of

But in any case, as mentioned by others here, multiple ZEO-clients and
load balancing fixes this for most cases.

I'm hoping I can garner some support to get the zope developers to fix the

Well, I'm sure it can be improved by throwing money on the right people... ;)

Lennart Regebro, Nuxeo     http://www.nuxeo.com/
CPS Content Management     http://www.cps-project.org/
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to